I have an interface:
interface DataExtractor {
public function extractData($dataSource);
}
I have ended up only having a single concrete example which is general purpose enough to serve all of my required needs.
Im am therefore left with an issue on what to name the concrete class and this leads me to ask if this is a code smell and i should not actually have the interface in the first place.
- DefaultDataExtractor
- BaseDataExtractor
- changing the interface to iDataExtractor and the concrete class to DataExtractor
These all seem wrong
Aucun commentaire:
Enregistrer un commentaire