dimanche 5 avril 2020

Implement a new feature with loose coupling

trait paymentTasks{
  def calculatePayment()
  def getData()
}

 class paymentcalculator{
    override def calculatePayment() ={
    //Implementation }

    }
    override defGetData() ={
    }
   }

How do I call the method to keep the code less dependent and don't want to use new keyword

 class MyApp{
   val payment = new paymentcalculator
   //I don't want to instantiate like this wants this to be decoupled

 }

Please suggest how do I implement this ,also new Changes in future can be done without changing existing code.Also,suggest if doing this functionally would be more effective

Aucun commentaire:

Enregistrer un commentaire